
Creating Accessible Content with Dreamweaver CS5  

Dreamweaver Features 

Accessibility prompts  

Dreamweaver has accessibility features that, when enabled, prompt the user to add accessibility 
attributes. 

 

To enable the accessibility features of 
Dreamweaver: 
 
Select Edit > Preferences > Accessibility 
and then check the boxes for Form objects, 
Frames, Media, and Images. 
 

 

Accessibility reporting 

 

Dreamweaver can validate against 
common accessibility standards and 
give feedback regarding the 
accessibility of web content.  

The reports can be accessed by 
selecting Site > Reports. 

Accessibility reference  

Among the other reference materials included in Dreamweaver, there is an Accessibility Reference, 
provided by UsableNet. Choose Window > Reference to open the reference panel at the bottom of 
the screen and select UsableNet Accessibility Reference under Book. 

Accessible authoring interface  

Most of the dialogs, menus, and other interface elements are accessible to screen readers. 
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Accessible Images 

 Use graphics to illustrate procedures, processes and concepts. 

 Make choose color combinations with enough contrast to be understandable when viewed 
without color. 

 Provide alternate text for all images. 
o Make sure the alternate text communicates the purpose of the graphic. 
o Provide empty or “null” alt text for graphics that do not convey content such as spacer 

gifs or decorator images. 
o Provide alt text for both the main image and the hotspots of an image map.  
o Limit the use of text within graphics 
o Ensure that animated graphics do not flicker between 2 and 55 times per second. 

Add alternate text for images, and image maps 

Images 

Choose Insert > Image  

Dreamweaver prompts 
the user for alternative 
text when an image is 
inserted into the 
document. 

 

 Limit alternate text to around 50 characters. 

 For longer descriptions, consider providing a link, in the Long 
Description text box, to a file that gives more information about the 
image. 

 Example of code for an image tag with a long description: 

<img src="emptyalt.gif" alt="properties panel with empty chosen" 
width="600" height="106" longdesc="longdescription.txt" /> 

 

If an image already 
inserted into your 
document needs 
alternate text: 

  
Select the image and type the alternate text in the alt box in the 
Properties panel 

 
Image Maps:  

Select the image map 
and add hotspots using 
the tools on the Property 
Inspector 
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With a hotspot selected 
you can add alternate 
text in the Property 
Inspector: 

 

Adding empty alt tags for decorative images, spacer gifs, etc. 

Sometimes it is appropriate to create empty alt tags (alt="") when the image is purely decorative or 
otherwise not essential to someone listening to the page with a screen reader. A screen reader will 
skip over an image marked with alt=””. 
 
To create an empty alt tag for an image in Dreamweaver:  

Select the image, click on the arrow at the right edge of the Alt text box and choose <empty>  

 

Accessible Forms 

Form labels  

Dreamweaver will prompt for appropriate labels when form elements are added to your web page. 

 

Type the appropriate form label into the 
Label dialog box.  

Select the label style and position. 

The best results are accomplished by 
selecting Attach label using 'for' attribute. 
This allows the form label to be moved to 
another position within the page and is 
most compatible with existing screen 
readers. 
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You still need to select the form object 
and change its default name in the 
Properties panel. 

 

 

 

 

 

f you chose "Attach label using 'for' " you 
have one more step:  

 Select the label text.  

 On the gray bar at the bottom of 
the window right click on the 
<label> tag and choose "Quick 
Tag Editor."  

 Change the default form object 
name to match -the name you 
gave it in the Properties panel.  

 

Frame titles 

,Dreamweaver will prompt you for frame titles when a new frameset document is created if the 
accessibility option for frames has been set within the preferences. 

  

The Title option should be a brief description of the frame contents or functionality. This information 
will be read by a screen reader to identify the frame. The Frame Tag Accessibility Attributes dialog 
will only be displayed if you create a new frameset document (File > New > Framesets) and will not 
display if you modify an existing document into a framed page (Modify > Frameset > Split Frame). 

Creating Accessible Tables 

 Layout Tables:  
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1. Ensure that the contents of the table make sense when linearized (i.e. when removed 
from the table). 

2. Do not use table headers (<th> tags) for visual effect. 
3. Use proportional sizing, rather than absolute sizing. 
4. Use the simplest table configuration possible. 

 Data Tables  
1. Designate row and column headers using the <th> tag. 
2. Associate the data cells with the appropriate headers. 
3. Use proportional sizing, rather than absolute sizing. 
4. Provide names or titles for data tables using the <caption> tag.  
5. Provide summaries using the summary attribute. 
6. Avoid spanned rows or columns. 
7. Avoid tables with more than two levels of row and/or column headers. 

Designate row and column headers using the <th> tag 

The first step toward creating an accessible data table is to designate row and/or column headers. In 
Dreamweaver, click in the cell that you want to designate as a header and then check the header box 
in the Property Inspector window: 

 

 In the markup, the <td> tag is used for table data cells and the <th> tag is used for table header cells. 
In the following data table example, the column headers for this table are "Name," "Age," and 
"Birthday." The row headers are "Jackie” and "Beth." 

Shelley’s Daughters 

Name Age Birthday 

Jackie 5 April 5 

Beth 8 Jan. 14 

Associate the data cells with the appropriate headers 

Now that we've created headers, we need to associate the cells with the appropriate headers. 
Unfortunately, there aren't many tools that will do this for you. You have to go into the markup and do 
it yourself. There are two ways to do associate data cells with their headers. 

1. Scope 

The scope attribute should be used on simple data tables such as the one in this example. Here is 
the markup for the table, using the scope attribute: 
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<table border="1" align="center"> 
<caption>Shelly's Daughters</caption> 
<tr>  
<th scope="col">Name</th> 
<th scope="col">Age</th> 
<th scope="col">Birthday</th> 
</tr> 
<tr>  
<th scope="row">Jackie</th> 
<td>5</td> 
<td>April 5</td> 
</tr> 
<tr>  
<th scope="row">Beth</th> 
<td>8</td> 
<td>January 14</td> 
</tr> 
</table> 

The scope tag tells the browser and screen reader that everything under the column is related to the 
header at the top, and everything to the right of the row header is related to that header.  

 

To use the Quick Tag Editor to add the scope 
attribute to the TH tag: 

 Select the text in a cell you have designated as 
a row or column header.  

 On the gray bar at the bottom of the window 
right click on the <th> tag and choose "Quick 
Tag Editor."  

 Then type in: scope="col" OR type: 
scope="row" in the Quick Tag Editor window: 

 

 

2. Headers and "id" 

Another way to accomplish the same purpose is to use the "headers" and "id" attributes. The markup 
looks like this: 

<table border="1" align="center"> 
<caption>Shelly's Daughters</caption> 
<tr>  
<th id="name">Name</th> 
<th id="age">Age</th> 
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<th id="birthday">Birthday</th> 
</tr> 
<tr>  
<th id="jackie">Jackie</th> 
<td headers="age jackie">5</td> 
<td headers="birthday jackie">April 5</td> 
</tr> 
<tr>  
<th id="beth">Beth</th> 
<td headers="age beth">8</td> 
<td headers="birthday beth">January 14</td> 
</tr> 
</table> 

This method is more complex. It should be used with tables of a more complex nature, where the 
scope attribute will not work. 

Provide names or titles for data tables using the <caption> tag 

Tables ought to have some sort of title or caption to them. This is properly done by using the caption 
tag, right after the opening <table> tag, like this: 

<table border="1" align="center"> 
<caption>Shelly's Daughters</caption> 

Provide summaries using the summary attribute 

This guideline is not a requirement for simple tables, but can greatly increase the comprehension of 
more complex tables. A complex table of weather data might have a summary that says: 

"A warming trend has been observed in Cache Valley, with temperatures about 5 degrees above 
historical averages over the last two months, with the highest temperature difference being 25 
degrees above average." 

Such a description would highlight the important elements of a table, and help the user to know what 
to look for in the data. 

HTML example: 

<table border="1" align="center" summary="A warming trend has been observed in Cache Valley, 
with temperatures about 5 degrees above historical averages over the last two months, with the 
highest temperature difference being 25 degrees above average."> 

Page Structure and Layout 

The main content should be visible near the top of the page, without any scrolling. Give as much 
space to the main content as possible and reduce the size of navigational features as much as 
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possible while still keeping them legible. Test your layout on people who have never seen the layout 
before. 

Provide a way to quickly get to the main content 

People using the keyboard or keyboard-emulation devices appreciate being able to skip past the 
navigational menu system, so that they can jump directly to the main content of the page. Imagine 
listening to, or tabbing through, a list of 13 items on every page before arriving at the pages' main 
content. It can be quite tiring. 
 
Method 1 - add a visible or invisible link to the main content 

 Insert an anchor at the beginning of the main content. (Insert -> Invisible Tags -> Named 
anchor) 

 You can make an invisible or visible link to skip to the main content. 

 To make an invisible link, put a transparent gif 1 pixel x 1 pixel before the navigation to be 
skipped. With the gif selected, type “skip to main content” in the alternate text box in the 
properties inspector. Link the gif to the anchor by typing # followed by the anchor name 
(#main).  
 

 
 
Alternative method for hidden links  

 Insert an anchor at the beginning of the main content. (Insert > Named anchor) 

 Put the link to main content at the beginning of the page.  

 Make a style for hidden text and apply that style to the link to main content 
 
NOTE: the hidden links to main content are easily read by screen readers. However, people with 
mobility problems who do not use screen readers will not benefit from the hidden links.  
 

Marking up quotations. 

There is an easy way to markup a section of text as a quotation using the <blockquote> tag. 
Unfortunately, Dreamweaver uses an icon that gives the false impression that the <blockquote> 
element is meant to be used for indentation purposes. In reality, this tag should only be used to set 
aside quotations.  
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Web Accessibility Standards and Guidelines 

Illinois Web Accessibility Standards (IWAS) 
http://www.illinois.gov/ito/iwas1_2.cfm 
 
W3C Web Content Accessibility Guidelines  
http://www.w3.org/TR/WAI-WEBCONTENT/full-checklist.html 
 
Section 508 Checklist 
http://www.webaim.org/standards/508/checklist 

Tutorials and Tools.  

ATRC Web Accessibility Checker - http://checker.atrc.utoronto.ca/index.html 
Adaptive Technology Resource Center (ATRC) at the University Of Toronto. The free accessibility 
checker evaluates your Web page and produces a report of all accessibility problems for your 
selected guideline. 
 
WebAIM Techniques and Concepts - http://www.webaim.org/articles/ 
This section of the WebAIM site features articles to help you understand the concepts as well as the 
techniques needed to design accessible web sites. 
 
Complete List of Web Accessibility Evaluation Tools  - http://www.w3.org/WAI/ER/tools/complete 
From the W3C Web Accessibility Initiative 

HTML Validation 

W3C Validation Service 
http://validator.w3.org 
 
W3C CSS Validation Service 
http://jigsaw.w3.org/css-validator 
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